The updated extension is live with version 3.1.1013. You don’t need to do anything to get the update as Chrome and other browsers will pull the update automatically.
We will continue to monitor the situation for a while.
Posted Jul 01, 2023 - 06:00 UTC
Identified
We're aware of an issue where clicking the "Language" button in the browser widget doesn't do what is expected.
We have identified the root cause and have developed a fix. It will take some time for Google to review the update, and we will update this incident once it is approved and live.
In the meantime, you can change the language through the meeting's settings.
Posted Jun 30, 2023 - 01:54 UTC
This incident affected: Browser Extensions (Chrome Browser Extension, Edge Browser Extension) and Transcription (Tactiq Transcription for Google Meet).