Tactiq web app unresponsive or loading indefinitely for some users
Incident Report for Tactiq
Resolved
This incident has been resolved and we have improved our infrastructure to reduce the chances of this happening again. Apologies for the inconvenience!
Posted Mar 28, 2023 - 21:40 UTC
Monitoring
A fix has been implemented and we are monitoring the results. The application should be back to normal. All meetings that were in progress should successfully save within a few minutes.
Posted Mar 28, 2023 - 14:30 UTC
Identified
The issue has been identified and we are working on a fix.
Posted Mar 28, 2023 - 14:20 UTC
Investigating
We are aware of an issue that manifests in https://app.tactiq.io 'loading' indefinitely, or, if you already had it open, becoming unresponsive.

We're looking into the root cause of the issue.
Posted Mar 28, 2023 - 13:58 UTC
This incident affected: Web Application and APIs (app.tactiq.io).